Time Tracker
Incident Report for The YOSS Platform
Postmortem

During a normal deployment from 9/11-9/12, we introduced a new Time Tracker feature to support multiple job codes. During this deployment, the primary issue encountered was a discrepancy between the newly updated database objects and the application code that was supposed to be deployed. While the database objects were successfully updated, it appears that the corresponding application code was not deployed as intended. This misalignment meant that the older version of the application code couldn't function correctly with the new database structures. This oversight was not immediately caught during our post-production validation, leading to the observed issues. A hot fix was deployed around 7:15am which rectified this problem. However, in deploying this hot fix, a secondary issue emerged where the new feature inadvertently forced users to input a job code, even when they didn't have a job code associated with their profile. By 8:15am, this secondary issue was also addressed, and the Time Tracker was fully operational. Further details about the new feature will be communicated in our upcoming release notes.

Posted Sep 12, 2023 - 08:47 EDT

Resolved
We wanted to let you know that Time Tracker had a brief period of down time this morning. This was resolved around 7:15am. If users report any issues after that time, please let us know.
Posted Sep 12, 2023 - 07:34 EDT
This incident affected: The YOSS Platform.