Accounts Payable 504 Errors

Incident Report for The YOSS Platform

Resolved

Good morning. This issue has been resolved. Please let our team know if you see any further messages or need assistance. Thanks!
Posted Mar 25, 2025 - 09:48 EDT

Investigating

Good morning. We are receiving reports that some users are receiving a 504 message when attempting to launch the administrative side of Accounts Payable. Our team is aware of this and is investigating. We will update this status as we have more information.
Posted Mar 25, 2025 - 09:25 EDT
This incident affected: The YOSS Platform.