Time Tracker

Incident Report for The YOSS Platform

Resolved

We have not received any further reports of any issues with time tracker. We are marking this as resolved. We apologize for the challenges faced with time tracker today.
Posted Mar 24, 2025 - 15:01 EDT

Monitoring

A fix has been implemented and users should be able to click in and out with no issues. If you see any further challenges, please let our team know. Thank you!
Posted Mar 24, 2025 - 09:38 EDT

Identified

The issue has been identified and a fix is being deployed.
Posted Mar 24, 2025 - 08:33 EDT

Investigating

We are currently aware of users experiencing issues clocking in via YOSS’s time tracker module and are investigating.
Posted Mar 24, 2025 - 07:53 EDT
This incident affected: The YOSS Platform.