Time Tracker

Incident Report for The YOSS Platform

Resolved

We have received no further reports of issues with Time Tracker. We are marking this incident as resolved.
Posted Apr 09, 2025 - 12:01 EDT

Monitoring

A fix has been implemented and our team is continuing to monitor to ensure things are functioning normally.
Posted Apr 09, 2025 - 08:00 EDT

Investigating

Our team has received reports that some employees are having challenges clocking in this morning. Our team is aware and investigating.
Posted Apr 09, 2025 - 07:44 EDT
This incident affected: The YOSS Platform.